Getting Started Manual

Tecplot Chorus 2017 Release 1
# Table of Contents

## A Virtual Tour

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening a Project</td>
<td>5</td>
</tr>
<tr>
<td>Exploring the Table View</td>
<td>8</td>
</tr>
<tr>
<td>Exploring the Matrix View</td>
<td>9</td>
</tr>
<tr>
<td>Matrix View Properties</td>
<td>12</td>
</tr>
<tr>
<td>Viewing Associated Images</td>
<td>13</td>
</tr>
<tr>
<td>Viewing Associated Data</td>
<td>14</td>
</tr>
<tr>
<td>Plots</td>
<td>16</td>
</tr>
<tr>
<td>3D Scatter Plot</td>
<td>17</td>
</tr>
<tr>
<td>2D Scatter Plot</td>
<td>19</td>
</tr>
<tr>
<td>Line and Symbol Plots</td>
<td>21</td>
</tr>
<tr>
<td>Sessions</td>
<td>22</td>
</tr>
<tr>
<td>What's Next</td>
<td>22</td>
</tr>
</tbody>
</table>
A Virtual Tour

Tecplot Chorus provides a robust framework for managing CFD projects, such as parametric studies, that require multiple simulation cases with tools to evaluate the results. You can evaluate overall system performance and visually compare tens or thousands of simulation cases in a single environment, helping you make decisions faster and with more confidence than ever before.

This tutorial will take you on a tour of Tecplot Chorus's most important visualization features, including:

- Opening a project
- The project views available in Tecplot Chorus
- Viewing images and data associated with cases in a project

What you should be doing during this tour is playing with the features as we introduce them. We’ll tell you what they do and what they’re for, but getting your hands on the product is the best way to become familiar with how it feels to work with it. You’ll be working only with sample data that’s included with your copy of Tecplot Chorus, so don’t worry about messing up or erasing anything.

1 - 1 Opening a Project

We’ll open an example project included with Tecplot Chorus. The example projects are stored in the `sampledata` folder in your Tecplot Chorus installation.
A Virtual Tour


The Welcome Screen on a fresh install of Tecplot Chorus lists the example projects under Recent Projects. If “Example 1” is listed, simply click it to open the project and skip the next step. If Example 1 is not listed, continue with the next step.

2. Choose File > Open Project, navigate to the sampledata folder inside your Tecplot Chorus installation folder, and open the file example1.chprj.
The project only takes a second to open; then the Tecplot Chorus Welcome Screen disappears and a Table View of the project appears.

Other views can be opened using the View menu or buttons on the toolbar. Don’t open anything yet, though; we’ll get to that soon enough.

What’s in a project? Each simulation you run with a different combination of input parameters (or independent variables) results in its own record in Tecplot Chorus, referred to as a case.

For each case, Tecplot Chorus keeps track of the simulation’s inputs (independent variables) and outputs (dependent variables) along with optional informational fields you provide and any associated image or data files. Since these pieces of information are “data about data” (where the solution files generated by the simulation are the actual data), they are sometimes collectively referred to as metadata.

For now, let’s just look at an existing project and see how it’s laid out.
1 - 2 Exploring the Table View

The Table View appears immediately when you open a project. You may also open a Table View at any time by clicking on the toolbar or by choosing View > New Table View. Here it is again (this time without the other parts of the Chorus workspace to distract you).

The Table View is the least interesting view from a visual standpoint, but it is incredibly useful for looking at the project’s actual numbers. And of course, it’s already open, since we just opened the project, so it’s where we’ll start.

Each row in a Table View represents a single case associated with a unique combination of input values. Poke around a bit and you can see that:

- Each case is represented as a row, and the values associated with it are represented as columns. Each case has the same set of variables.
- Tecplot Chorus assigns each case a numeric Case ID. The first Case ID is 1, and each new case imported is assigned the next number higher. This can be useful shorthand when discussing a particular case with others.
- We can easily tell that there are 191 cases in the project, because the highest Case ID is 191. (Scroll down to the bottom to see.)
- Besides the Case ID, there are seven additional columns, labeled “Mach No.,” “Alpha,” “Beta,” “# Iterations,” “Lift Coef.,” “Drag Coef.”, and “Pitch Mom. Coef.” You may need to scroll right to see all of them. Each column represents a variable. Aerospace engineers will recognize the first three as common independent variables (inputs to a simulation) and the others as likely dependent variables (outputs from the simulation).
- There are subtle tick marks at the top of each cell. These indicate where each cell’s value falls within the range of the variable in the project, with the left edge representing the minimum
Exploring the Matrix View

value of the variable and the right edge representing the maximum. As you scroll down in the table, then, the tick mark in the Case ID cells moves predictably from left to right. Check out how it moves in other columns, which are not necessarily in order.

- If you’ve been playing with the filters, you may see shading in some columns, or some of the values being displayed in red rather than in black, to help visualize the effects of the filters. The shading represents the proportion of low and high values being filtered out. A value is colored red if it violates the column’s filter.

It is also possible for a project to include variables that are informational in nature, rather than being inputs or outputs. These might record the date, the identity of the engineer who ran the simulation, what cluster it ran on, and similar housekeeping information. This example project doesn’t have any such variables.

It’s also possible to append additional cases and variables to a project, and also to calculate variables within Tecplot Chorus. (See Chapter 2 in the Tecplot Chorus User’s Manual for more details.) You can sort the table in ascending order on a variable by clicking a column header. Clicking the same header a second time sorts in descending order. This makes it easy to determine the range of any variable in the project. Try it out!

There’s a view similar to the Table View that shows only the selected cases. You can show it by choosing Selected Cases from the View menu. It’s particularly useful for seeing the values of cases you’ve selected in other views.

1 - 3 Exploring the Matrix View

The Matrix View lets you visually sift through the cases in your project using image thumbnails associated with some or all of the cases in the project. Rows, columns, and optionally pages can be assigned to represent any variable in the project.

To open a new Matrix View, choose View > New Matrix View, or click in the toolbar. The Matrix View appears next to or partially on top of the initial Table View, depending on how much room is available in the Tecplot Chorus workspace.

Managing Windows Each time you click a toolbar button to open a view or plot, Tecplot Chorus opens a new view or plot of that type, even if you already have one open. Tecplot Chorus tries to position the new window so that you can see at least parts of some of your other windows, but there isn’t always room.

If, when you open a window, that plot covers an existing window, the existing window is still there, but hidden. Don’t worry that you have “lost” a plot you have painstakingly set up when you open a new one; the old plot is still there behind the new one.

Click the button in the toolbar to display all open windows in a grid, making it easier to find the one you want.
A Virtual Tour

In our initial view (yours may be different depending on how you’ve sized the Tecplot Chorus window), only a few image thumbnails are visible.
Exploring the Matrix View

If your screen is small, you might want to maximize the window so it uses all of the workspace, then use the Zoom slider in the lower right corner of the window to make the thumbnails as small as possible, so you can see more of the cells in the Matrix View. You should be able to fit most or all of them in, like this:

At this point, you can see:

- Some cells in the matrix are blank. In the example project, some of these are missing cases—simulations that haven’t been run. Real projects will often be even more sparse.
- Another reason a matrix cell might be blank is that none of the cases that belong in that cell have an image associated with them. This isn’t the situation in the example project, however.
- Tecplot Chorus has assigned the variables Mach No. and Alpha to the rows and columns of the matrix, respectively. You can change these variables.
- Each discrete value of each variable gets its own row or column.

Try clicking on some cases. If you can still see the Table View you already opened, you will notice that when you click a cell in the Matrix View, the corresponding row in the Table View, if it happens to be visible, is highlighted. In Tecplot Chorus, selecting a case in one view selects it in all views. You can open a special, dockable Table View that shows only the currently selected cases by choosing View > Selected Cases.

It is possible to select multiple cases in the Matrix View. Try clicking the row or column headers instead of just on the matrix cells, and also try holding down Control, Shift, or both while you click cells or headers. See if you can figure out:

1. The quickest way to select just columns 0.2, 1.2, and 1.8
   
   Answer: Click the header for column 0.2, then hold down the Control key while clicking the headers for columns 1.2 and 1.8.
2. The quickest way to select the last three rows

1 - 3.1 Matrix View Properties

The Properties panel in the Tecplot Chorus sidebar lets you choose the
options for the Matrix View. You’ll probably find this at the left of the Tecplot
Chorus workspace. If the Properties panel is not already open, choose View >
Properties to open it.

Each open view or plot has its own properties, even if the views are of the
same type. If you have more than one Matrix View open, for example, each
Matrix View has its own properties, which are completely independent of
any other Matrix View’s properties.

If you explore the Matrix View Properties for a few moments, you will
discover:

- You can change the variable used for the rows and columns in the
  matrix. Try Mach No. against Alpha, then Alpha against Beta.
- You can choose a third variable for paging. Since you’re now using
  Alpha and Beta for the rows and columns, try choosing Mach No.
  as the paging variable, then flip among the pages using the slider in
  the Properties panel.
- You can use the four dependent
  variables as rows, columns, and
  pages too! Usually this isn’t very
  useful; most of the time there are
  many different discrete values of
  dependent variables in a project, so
  you’d end up with a lot of rows or
  columns for that variable, making
  your images very spread out and
  hard to work with. However, you
  might give # Iterations a try. Here it
  is with Mach No.

Notice how some of the cells have a

| badge on them? This badge
| indicates that there are multiple
| cases that have the same value of
| the variables being represented as
| rows, columns, and pages, and that
| more than one of these cases have

---

1. Answer: Click the last row’s header, then hold Shift while clicking the second-to-last header.
associated images. Hover over a thumbnail with a badge and you’ll see how many images are “stacked” in that cell via tooltip. The highlighted cell in the matrix represents seven images in total: the one whose thumbnail is shown, and six additional images.

In our example project, all the cases have images, so these seven images correspond to seven cases. Select the cell in the matrix and switch to the Table View (or open the Selected Cases view), and you can see that all seven of these cases are in fact selected.

- The Show menu in the Properties panel shows only “Contour Image” as an option. Each case can have multiple images associated with it, although our sample project has only one kind of image. If there were multiple images associated with cases in the project, you could use this menu to choose which images you wanted to see as thumbnails in the matrix.

To review: Tecplot Chorus chooses thumbnails based on the variables you’ve chosen for the rows, columns, and optionally pages of the matrix. If multiple cases match these variables and have images, Tecplot Chorus chooses a representative case for the actual thumbnail display. You can turn on labels in the sidebar to see the value of unused variables, and you can use filtering to indirectly choose these values. We won’t talk about filtering in detail this lesson, but you might want to give it a try in the Filters sidebar.

**1 - 4 Viewing Associated Images**

Every thumbnail in the Matrix View represents one or more cases in your project—well, a case that has one or more images associated with it. (Cases that don’t have images look just as blank as cases that haven’t been run.) To view these images full-size from a Matrix View, follow this general procedure.

1. Choose the type of image you want to view using the Show menu in the Properties sidebar. In our example project, only Contour Image is available.

   When your project has more than one type of image, you can view images of kinds other than that displayed in the Matrix View, but switching the matrix to show the kind of image you’re interested in will make it easier to find the cases that have those images.

2. Select the case or cases for which you want to view the associated images.

   Don’t worry if you select some cases that don’t have an associated image (that is, cells that are blank in the matrix). Tecplot Chorus will ignore these when you tell it to view images.

3. Click the right mouse button while pointing at a selected image and choose View Images. The images appear in a separate window.
A Virtual Tour

The image window has its own Properties, just like any other view in Tecplot Chorus. You may want to experiment with:

- Turning on labels to see the values of some or all of the variables associated with each case (the image viewer window shown here already has labels turned on).
- Choosing a different type of image. There isn’t one in this project, but if there were, you could select it using the Tag menu in the Properties sidebar.
- View all variable values for the selected case. They appear right in the sidebar when you click an image.
- View difference images from a selected image. Just click an image to select it as the master (the image that others will be compared to), then click Diff From Current. A new window opens with the differences among the images.

Congratulations! You now know how to view images, and differences among them, in any of Tecplot Chorus’s views—because they all work the same way. Go back to the Table View that opened when you opened the project (or open a new one), select a few rows, and right-click. From there, it’s the same. Keep this in mind when we later visit the three types of plots available in Tecplot Chorus.

1 - 5 Viewing Associated Data

We’ve just seen how to view the image files associated with a case from a Matrix View. Cases may also have one or more data files associated with them. In fact, if you are familiar with CFD workflows, you already know that the image files are usually created from a solution data file, typically as a post-processing step invoked by the solver or from a script. Tecplot Chorus can also create images from your data files, though we won’t get into that in this lesson. For now we’ll focus on just viewing the data files.

Tecplot Chorus uses Tecplot 360 EX to view data. Tecplot 360 EX can read data files in a wide variety of common CFD solver output formats, create publication-ready plots and animations from them, and perform additional analysis on the raw results.

When you invoke Tecplot 360 EX to open a data file associated with any case or cases in Tecplot Chorus, we call this a “deep dive.” You have seen thumbnails and maybe a few larger images; this is the “surface” of your project’s “ocean of data.” By opening the actual data files associated with a case in Tecplot 360 EX, you go deeper: you can zoom in and rotate the plot, add contouring and axis labels, drop a few slices, and so on, to get a real idea of what your data is telling you.
The procedure is almost identical to the one just described for viewing images. The only difference is that you choose View Data instead of View Image after you click the right mouse button. Tecplot 360 EX launches, opens the selected data files (each in a separate frame), and gives you control.

When you're in Tecplot 360 EX, you’ll see an additional sidebar (shown docked on the right here) titled Chorus that controls integration between the two products. The sidebar includes Tecplot Chorus features that work inside Tecplot 360 EX.

For example, you can compare data, just as you can compare images in Chorus. Just click the frame that you want to compare the other frames to, click the Set Current Frame as Master button, then activate the Show diff data checkbox.

Feel free to play around with the other features in the Chorus sidebar, but don't invest too much time in figuring out what they do, because we're about to tell you:

- The View Page section lets you manage pages opened by Tecplot Chorus. Each time you tell Tecplot Chorus to open data, the data is placed on a new page rather than opening a whole new instance of Tecplot 360 EX.
- The Label Frames section lets you choose what variables appear in a label on the plots.
- The Save as Style Template button lets you save the style (appearance) of a plot in a separate file. The style can then be applied automatically to other data files to generate new images, which you then have access to in Tecplot Chorus.
- The Synchronize Styles button lets you copy the style (appearance) from the currently selected frame to all the other frames.

Don't worry if this doesn't quite hang together just yet. This lesson is intended to familiarize you with the basic Tecplot Chorus feature set, helping you understand when you'd use each feature and how to get to it. We've roamed pretty far afield, taking you into Tecplot 360 EX with its own rich set of features. The takeaway from this part of the lesson is just that the two applications, Tecplot Chorus and Tecplot 360 EX,
A Virtual Tour

are tightly integrated and work together in harmony, one showing you the forest and the other showing you the trees.
So spend a little time playing around if you like, then exit Tecplot 360 EX so we can get into the Tecplot Chorus plots.

1 - 6 Plots

Enough with the tables and matrices. Let’s look at some eye candy. Tecplot Chorus offers three types of plots, accessed using buttons on the toolbar or commands on the View menu.

3D Scatter Plot
2D Scatter Plot
Line Plot

We’ll soon share a brief look at each type of plot. But first, familiarize yourself with these tools, which we’ll use for manipulating our plots.

Select - Lets you select individual cases or groups of cases in plots and other data views.
Translate - Lets you move 3D plots within their window. For 2D and line plots, the axes stay in place while the data moves (that is, the axes’ ranges change).

Rotate - Lets you rotate 3D plots. Not available for 2D or line plots.
Zoom - Lets you zoom in and out of plots.

You may also zoom plots when any tool is active by placing the mouse pointer in the window to be zoomed and moving the mouse’s scroll wheel.

These controls work slightly differently in the various plots. See if you can discover the differences (or check Chapter 1 of the Tecplot Chorus User’s Manual for the full description).
Choose View > Reset to return a plot to its default view.
1 - 6.1 3D Scatter Plot

The 3D Scatter Plot, arguably the snazziest plot in Tecplot Chorus, is accessed by clicking on the toolbar or by choosing View > New 3D Scatter Plot.

Each sphere in the scatter plot represents a single case in your project. Since this is 3D, let's have some fun rotating it! Click the Rotate icon in the Toolbar and then click and drag in the plot window. Viewing your data from a new angle literally gives you a new perspective on it.

In the Properties sidebar, you'll see many options for changing the appearance of your scatter plot. (For now, ignore the options for under the heading Surrogate Model.) In particular, we'd like to draw your attention to the following:

- You can choose the variables to be displayed on the X, Y, and Z axes. Commonly you will choose two independent variables on the X and Y axes, and a dependent variable on the Z axis. However, sometimes you might want to use other setups. Using a third independent variable can reveal clustering of cases around a few parameter values. Using an informational variable (such as date or staff member) on Z organizes your cases into layers, where all the cases on each layer were run, for example, on the same date or by the same staff member. Using more than one dependent variable can reveal correlations.
- You can change the range of each axis. The defaults show every value from the minimum to the maximum value of the variable selected on the axis.
- You can have the color of each dot determined by a variable, which can be one of the variables on the plot's axes or a fourth variable. The lowest values of the variable are colored blue and the highest are colored red, with a rainbow spectrum of values in between.
In our example project, coloring by Case ID shows us which cases were imported into Tecplot Chorus first (they're blue) and which were imported later (they're red). Or you could color by # Iterations, which will assign a color indicating how many iterations a case took to converge on a solution.

You can turn on a legend that shows the mappings of values to colors. Drag the legend around the plot to position it wherever you like. Check out what happens when you move the legend to the top or bottom of the plot. You may also choose the approximate number of steps in the legend.

- Just as you can choose to have the color of each case determined by a variable's value, so too can you have its size determined by a variable's value. (You can also change the sphere to a square.) Try using Beta and a scaling factor of 0.5. Then try cubes!
- You can also save a plot as an image by right-clicking. Give that a try too. Images are saved in Portable Network Graphics (PNG) format.

Remember earlier when we mentioned that you can open multiple instances of any plot or view, each with its own properties? Give that a try too: open two 3D Scatter Plots, rotate them differently, and give each its own axis settings and visual look using the Properties panel.

It's important to note that you can select cases in a scatter plot. So it's not just a plot; it's also another way into the cases in your project! (All the Tecplot Chorus plots work this way.) Choose the Select tool on the toolbar, then click a few of the spheres or cubes. Hold down Control while clicking to select multiple cases, or drag out a rectangle around a group of cases that you want to select.

Synchronized Selections If you have other views or plots open, you will see that the cases you select in the 3D Scatter Plot are also selected in the other views. This is a Tecplot Chorus universal: cases that are selected in one plot or view are selected in all plots or views. We won't mention it again, but it will continue to hold.
Once you’ve selected a case or six, click the right mouse button. You’ll see that you have the same options here for viewing images or data that we talked about when we were discussing Matrix Views. Go ahead and try them out, if you like, just to confirm that they work the same.

**1 - 6.2  2D Scatter Plot**

The 2D scatter plot is similar to the 3D one we’ve already described, just flatter. You only get to specify variables for the X and Y axes, and of course you can determine the color and size of the scatter symbols by a variable, if you like.

An interesting 2D Scatter Plot to make with our example project has Alpha and Lift Coef. on the X and Y axes, respectively, and is colored using the # Iterations variable. Add a legend and position it out of the way of the data. The resulting plot reveals that Alpha has a nearly linear positive effect on lift, and also that most of the cases took 200-250 iterations for the solution to converge.
Switch the X-Axis variable to Beta, and it is clear that Beta’s relationship to lift is more complicated.

Plotting one dependent variable against another can reveal correlations. Here’s a plot of lift vs. drag (colored by Mach No.) revealing that at a given Mach No., lift and drag have a seemingly quadratic positive relationship:

As with the 3D Scatter Plot, you can select cases in your 2D Scatter Plot to view their images or data using the **Select** tool. Give it a try, clicking with and without the Control key and dragging rectangles around cases. Then right-click and view the images or data associated with the selected cases.
If you’ve been playing with the filters, and have set coloring to “Color by Filter Violations,” you may see shading on the plot. This visualizes the effect of the filters active for the axis variables. The individual cases are colored according to how many filters they violate (see the legend for the details).

**1 - 6.3 Line and Symbol Plots**

Tecplot Chorus’s Line Plot ([button or View > New Line Plot](#)) is actually three plots in one, because it can display a symbol for each case, lines connecting the cases, or both symbols and lines. Although, on the surface, it has less “wow” factor than, say, the 3D Scatter Plot, the humble line plot is a versatile tool for communicating results. Why not follow along and try to reproduce our plots? The controls are similar to the ones we’ve already seen for the other plots, albeit slightly more limited in some ways. As with the 3D Scatter Plot, just ignore the Surrogate Model section in the Properties panel for now.

In addition to the axes, you can also choose to group by and/or sort by an additional variable. Grouping on a variable causes each discrete value of that variable to be drawn as its own line, in its own color. That’s how we made the plot below.
A Virtual Tour

Can you find the exact settings we used for this plot?1

As always, you can select cases and view images or data for them. By now, that should be old hat. We’ll just note here that turning on symbols in a line plot is very handy for figuring out where the cases actually are on otherwise smooth, featureless lines.

1 - 7 Sessions

We’ll end this lesson with the concept of sessions. A Tecplot Chorus session remembers which project you were working with, the windows you had open, their positions and sizes on your desktop, and all their settings in the Properties sidebar. It’s a convenient way to save where you are, either to always begin your work in Tecplot Chorus in the same place (using the same session each time) or to return to exactly where you left off (using a session file you saved the last time you quit). Like projects, recently-used sessions appear on the Welcome Screen for convenient access.

You can find the commands to load and save Tecplot Chorus sessions on the File menu. Also, when you quit Tecplot Chorus, you’re offered the option to save the session right then and there. Your mission: create a session file to record where you are right now, then exit Tecplot Chorus, relaunch it, and open the session you saved.

1 - 8 What’s Next

We’ve shown you many of Tecplot Chorus’s major high-level features. Now would be a good time to look at Chapter 1 of the Tecplot Chorus User’s Manual, if you haven’t already. It explains many of the concepts and user interface elements behind the product and will help tie together the tour you’ve already taken.

Topics of particular interest include:

• How to create projects and import data. This is how Tecplot Chorus knows what variables you’ve used and their values for each case. You can also append new data as it becomes available—new cases, new variables, or both.
• How to set up filters so you can easily find the cases you’re interested in. Filters also have relevance in Matrix Views and in Surrogate Models.
• How to create new image files using existing data files. We touched on this capability in this tour (it’s part of the integration with Tecplot 360 EX).
• How to use a Surrogate Model to approximate the results of simulations or experiments you haven’t run yet, helping to identify potential regions of interest in your design space.